Stuck on checkpoint [Solved]

Hello, i need help.
i had some WETH in matic network and i am trying to migrate it back to ETH mainnet with no luck.

as you can see in this screenshot, i’m clicking continue and it’s loading forever. there’s no notifications in metamask for approving tx or anything. it just loading.

i have tried to reset metamask and installing it in different browsers, same issue there.
please help me, thank you!

That’s my ethereum address if you need it, 0xc7359585A1EBBB5a11509ca0ef5f128781362af3

and here’s the first tx i did for withdrawal of ETH to mainnet

I’ve found the issue. i have recently installed AdGuard which blocks the metamask from openning up when clicking continue. disabling AdGuard fixes it

Hi EtayM, would you mind explaining if the ‘transaction fee’ will be deducted from the Matic Wallet, as Matic or does it need Eth to make the transfer? At the above screenshot, its throwing 400$ + for transferring just 150$ of WETH. Also, how can I reduce such high transaction fees at the above point.

if your tx is stuck for 24 hours please provide your tx here it will initiate a burn immediately.