Problem moving WETH to ETH (RESOLVED)

[Note: I tried to embed screenshots to help explain but as a new user I’m only allowed to embed one image and five links, hence this link to Imgur.]

Two days ago I tried to move WETH to ETH and, received the “Checkpoint arrived. Your transaction is checkpointed on Ethereum network. You need to confirm one more transaction to get your funds in your Ethereum account,” after which I received the error, “Oops our servers stumbled somewhere. We have fired off a notification to the team to investigate. Please try again after some time.”


I thought it might be a glitch, so I waited until 7am EST Wednesday and tried again with the same result so I reached out to Polygon Support. They replied:

This is an update for all users who have been facing issues with withdrawal.
Our Tech team has identified and fixed the issue. Please hard refresh your
page once and try also as an alternative you can process your transaction
via We regret the inconvenience
caused here and would be taking steps to ensure this doesn’t occur again.

I followed their instructions and was prompted to initiate the second half of the transaction. When I did, it paused at this screen for awhile before presenting me with this partial message:

Transaction was not mined within 750 seconds, please make su".

Eventually I was prompted to retry the transaction, which after awhile looped me back to the same screen, with the same error at the bottom, “Transaction was not mined within 750 seconds, please make su.”

When I click “View on Etherscan” I receive this message, “Sorry, We are unable to locate this TxnHash”


I wrote back to Polygon Support letting them know their instructions did not work and that I was stuck in a loop. They replied:

We see that your withdrawal transaction is stuck. To proceed with the
withdrawal, please use the below tool wherein you just have to paste
the burn hash of your tokens and complete your withdrawal.

Do read the instructions provided there for a better understanding of the usage.
Please note, switch to the POS side on this tool.

I went to the site, read the instructions, “To find your burn transaction hash go to → this link and look for the transaction with which you initiated the first step of withdraw process on Polygon chain.”

I clicked the link in the instructions, found the transaction hash:


From there I copied the transaction hash: 0x4498e0a4dc1cd83ff0384b3f7094a2da47da75f8096e0786917da9f09230976d


I went back to the tool where I pasted the hash and hit withdraw.


I confirmed the transaction:


And the transaction eventually failed with the following error:


I tried it again several times throughout today with the same result. I’ve reached out to Polygon but haven’t heard back since this morning.

UPDATE: Friday Morning

Polygon support replied asking me to try the process in an alternate browser, which I did. Previously I had been trying this on a MacBook (11.4), Chrome (92.0.4515.131), MetaMask (10.0.2). I tried again on the same MacBook, with FireFox (88.0.1) and MetaMask (10.0.2) and it worked! The status is listed as “Success,” the transaction is showing up on Etherscan and the ETH is showing in MetaMask.

Hope this is helpful to someone else!


1 Like

Thank you for your reply. I created a ticket Wednesday morning: #2960

Hello @MrBenFT

Your complaint has been received and would be attended to. Kindly contact the live chat or a telegram DEv on Polygon support live chat website for more assistance with this ticket Id #2960.