No longer able to deploy

Yesterday and I today I was able to deploy to Mumbai for testing w/o any problems (0x4E22708AEbB2D6a0A8a22e119684ec48654100b8 - Mumbai Explorer)

Since then over last 8 hours or so when I’ve tried to deploy and run my tests and it just hangs after my contracts compile. Occasionally, if I don’t cancel the migration, I’ve seen this error:

Error: PollingBlockTracker - encountered an error while attempting to update latest block:
Error: getaddrinfo ENOTFOUND

It looks like this error is in the eth-block-tracker library’s _performSync function.

Furthermore, if I let it timeout, I’ve seen this:

Error:  *** Deployment Failed ***

"Migrations" -- Transaction was not mined within 750 seconds, please make sure your transaction was properly sent. Be aware that it might still be mined!.

Here’s what my config looks like:

 //polygon Infura testnet
    polygon_infura_testnet: {
      networkCheckTimeout: 100000,
      provider: () => new HDWalletProvider(mnemonic2, `${projectId}`),
      network_id: 80001,
      confirmations: 2,
      timeoutBlocks: 50,
      skipDryRun: true,
      chainId: 80001,
      gas: 1000000, 
      gasPrice: 7000000000,

Not sure if it’s an Infura issue, Truffle issue, HDWalletProvider issue, or Matic issue?

Anyone happen to have thoughts? Appreciate your help.

Do you see the transaction hash appear?

I am getting the same issue. Ive tried different providers, different gas limits and prices, and it is absolutely killing me.

To resolve this I deployed from a different wallet. Have you given that a try, yet?

Yeah I’ve tried different addresses, rpcs, increased gas price etc. Transaction gets broadcast to network but even with 25 gwei doesn’t get picked up. ://

Curious as to whether the issue has persisted for you @Dopamine and whether you were deploying to mainnet or Mumbai.

It is so frustrating to use matic. I could not able to deploy using polygon infura as well. None of the truffle configs worked for me. I still get Timedout issue.

Its really frustrating. What kind of support do you guys actually provide? When trying to register everytime it says captcha error. I could not even signup.

Come on guys this is terrible support…

You have to provide INFURA project Id. is projectId set?

For me I am it works fine for Mumbai testnet but really frustrating for mainnet.

I’m still having this issue when trying to deploy with truffle. truffle-config looks like:

    matic: {
      provider: () => new HDWalletProvider(mnemonic, `'process.env.APPKEY),
      network_id: 137,    // # Polygon network ID (default: 137)
      confirmations: 2,   // # of blocks to confirm deployment (default : 0)
      timeoutBlocks: 200, // # of blocks before deployment time runs out (default : 200 )
      skipDryRun: true,   // Simulated dry-run (default: false)
      networkCheckTimeout: 100000

Not sure what to do, adding networkCheckTimeout seems to do nothing.

1 Like