My metamask will not connect to Matic Network at all!

I am in a desperate situation now! Yesterday I borrowed from Aave twice the same exact way. One time though the funds, USDC, simply never arrived in my wallet. I checked on the polygon blockchain explorer and everything looked fine and claimed to be delivered. I never saw the funds at all. Today however Matic wouldnt work at all. I tried to disconnect the network and reconnect to no avail with various rpc designations. Losing these funds is a real disaster for me, please I need help!

Hello @survivanz
Thanks for reaching to Polygon Forums.

Customer service may take some time to respond due to a large number of requests. We believe your case will be resolved as soon as possible. Kindly visit the Matic support live chat website

Ok please help as soon as possible. there may be a fundamental problem …i tried to send 20 in USDC to metamask wallet and it hasnt appeared in my wallet.

@survivanz Kindly visit the Matic support live chat website for more assistance on this issue