Missing Ether on Matic Web Wallet

I was attempting to move some ether from the matic network over the POS bridge to the eth network. The eth is visible from metamask, however, it is NOT visible on the matic web wallet. Since it doesn’t show up in the web wallet, I am unable to transfer any amount across the bridge.
I swapped my eth to matic using Quickswap and my balance was updated on the web wallet and I can transfer the newly converted tokens across PLASMA though I’d like not to wait 7 days. Swapping back to eth, my matic balance was properly reduced but it still showed 0 eth on the web wallet. I know the transaction went through properly because my metamask shows I have eth.

Is there a fix for this? Am I overlooking something? Thanks.

Same problem. ETH showing in metamask but not in web wallet.
I googled and this problem seem to be known for almost a year and they don’t fix this.
Clearly need to avoid matic at all costs from now on.

Hello @Moody @David_Barrera
Thanks for reaching to polygon Forums. Customer service may take some time to respond due to a large number of requests. We believe your case will be resolved as soon as possible. Kindly visit the polygon support live chat website

Having the same problem. Thought this was a temporary issue at first, but it’s been going on for a while.
Tried changing RPCs, but no luck.
Is it possible to call the bridge contract directly without going through the frontend?

Do not go to that link by @Shunman_dev, they are trying to scam you into providing your wallet seed phrase. Some BS about your wallet not being connected to Polygon properly.

@David_Barrera @Moody I managed to resolve this buy swapping my Eth to DAI and back to Eth again.
Not sure how or why that worked, but maybe it’ll help you too.