Login Issues with Metamask

I am having trouble logging into my metamask at the login screen at wallet.polygon.technology. It prompts me to sign into metamask and when I do, it leaves me back at the login screen instead of logging me in. I’ve even tried it manually at support-matic.network. I’ve tried via secret phrase and private key and both tell me “Secret phrase is invalid”. My private key can’t be invalid though because I copy paste it straight from my metamask extension.

I have also talked to live support chat 3 times now about the issue and all 3 times I have been ignored once they understand my situation. I need an answer here at this point because customer support is unable to give me one.

1 Like

Experiencing the same issue. Have you managed to fix the problem?

I’ve got nothing. Just going to avoid matic from now on I think

1 Like

Sent you a dm on what to do , kindly let me know if you need your way around it.

What was the solution? I’ve had same issue for a week and no help or answer anywhere

1 Like