Failed to start bor

Hello,

I tried to set up a null node and followed this page:Full Node Binaries | Matic Network | Documentation

After Heimdall was synced and I tried to start bor, I got this error:
Jun 19 14:17:01 systemd[1]: bor.service: Failed to load environment files: No such file or directory
Jun 19 14:17:01 systemd[1]: bor.service: Failed to run ‘start-pre’ task: No such file or directory
Jun 19 14:17:01 systemd[1]: Failed to start bor.

I used “journalctl” to check log and it showed as follows:
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.552] Stopping peer for error module=p2p peer=“Peer{MConn{207.180.214.22:26656} c694d54a5b59dbf698206d04a3693b12a8c18251 out}”
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.580] Stopping peer for error module=p2p peer=“Peer{MConn{95.217.118.207:46656} 4a4d92f367cb6075f930336b795b034fc00b888e out}”
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.611] Stopping peer for error module=p2p peer=“Peer{MConn{52.21.112.201:26656} 2e6a7e393185f10e069579af120326d5fc3d2c86 out}”
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.615] Stopping peer for error module=p2p peer=“Peer{MConn{54.163.119.243:26656} 1f1b21cacf3ac8a1e1402646e023811b250e2d76 out}”
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.616] Stopping peer for error module=p2p peer=“Peer{MConn{3.22.45.51:26656} d7e71307f71acb0c5c7bd1cfc8a3928ba6f6510a out}” err
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.962] dialing failed (attempts: 1): dial tcp 140.82.39.211:26656: i/o timeout module=pex addr=0e034f6e8185eb213359f703fb9ad2bcecedff7e@140.82.39.21
Jun 19 14:18:15 heimdalld[2849]: E[2021-06-19|14:18:15.962] dialing failed (attempts: 4): dial tcp 15.236.46.160:26656: i/o timeout module=pex addr=b233c735eb03e799539b68de48b508483503c259@15.236.46.16
Jun 19 14:18:18 heimdalld[2849]: E[2021-06-19|14:18:18.170] dialing failed (attempts: 2): auth failure: secret conn failed: read tcp 192.168.1.226:36596->95.216.225.22:26656: i/o timeout module=pex add
Jun 19 14:18:20 heimdalld[2849]: I[2021-06-19|14:18:20.466] Executed block module=state height=5504310 validTxs=0 invalidTxs=0
Jun 19 14:18:20 heimdalld[2849]: I[2021-06-19|14:18:20.512] Committed state module=state height=5504310 txs=0 appHash=D7C6EC46356669E35A0612C9A4821F36EF0C2E28DBE7A78F4421D7
Jun 19 14:18:20 systemd[1]: bor.service: Service hold-off time over, scheduling restart.
Jun 19 14:18:20 systemd[1]: Stopped bor.

Did someone experience the same and could you give me some guide? Thank you.

I have same problem. When I look at the logs it appears it’s looking for a missing file

Jul 01 00:16:46 sentry001 systemd[1]: Failed to start bor.
Jul 01 00:16:51 sentry001 systemd[1]: bor.service: Scheduled restart job, restart counter is at 4.
Jul 01 00:16:51 sentry001 systemd[1]: Stopped bor.
Jul 01 00:16:51 sentry001 systemd[1]: bor.service: Failed to load environment files: No such file or directory
Jul 01 00:16:51 sentry001 systemd[1]: bor.service: Failed to run ‘start-pre’ task: No such file or directory
Jul 01 00:16:51 sentry001 systemd[1]: bor.service: Failed with result ‘resources’.
Jul 01 00:16:51 sentry001 systemd[1]: Failed to start bor.
Jul 01 00:16:57 sentry001 systemd[1]: bor.service: Scheduled restart job, restar

I did the following to get BOR to start properly:
cd /etc
sudo mkdir matic
cd matic/
sudo touch metadata

I also encountered bor cannot be synchronized:
Jul 01 14:35:23 matic bash[1353559]: INFO [07-01|14:35:23.639] Looking for peers peercount=0 tried=63 static=0
Jul 01 14:35:26 matic bash[1353559]: ERROR[07-01|14:35:26.286] Snapshot extension registration failed peer=b2a05910 err=“peer connected on snap without compatible eth support”
Jul 01 14:35:34 matic bash[1353559]: INFO [07-01|14:35:34.779] Looking for peers peercount=0 tried=51 static=0
Jul 01 14:35:44 matic bash[1353559]: INFO [07-01|14:35:44.852] Looking for peers peercount=0 tried=99 static=0
Jul 01 14:35:54 matic bash[1353559]: INFO [07-01|14:35:54.965] Looking for peers peercount=0 tried=23 static=0
Jul 01 14:36:05 matic bash[1353559]: INFO [07-01|14:36:05.074] Looking for peers peercount=0 tried=59 static=0
Jul 01 14:36:15 matic bash[1353559]: INFO [07-01|14:36:15.425] Looking for peers peercount=0 tried=82 static=0
Jul 01 14:36:25 matic bash[1353559]: INFO [07-01|14:36:25.691] Looking for peers peercount=0 tried=44 static=0
Jul 01 14:36:35 matic bash[1353559]: INFO [07-01|14:36:35.796] Looking for peers peercount=0 tried=34 static=0

Same error here #1844

this can be circumvented by adjusting systemd config, specifically setting StartLimitBurst to 0 which disables the check

make sure service not running first

sudo service bor stop

find systemd config to adjust:

systemctl show -p FragmentPath user@0.service #FragmentPath=/usr/lib/systemd/system/user@.service

sudo vim into fragment file above and add the following in [Service] section:

StartLimitBurst=0

esc :wq! to save changes and exit

reload systemd file with new config

sudo systemctl daemon-reload

sudo service bor restart

…worked for me!