Can't move USDT or Matic on Polygon network from my MetaMask wallet after using

I tried to bridge USDT on Polygon network to eth network via ‘Evodefi | Cross-Chain Token Bridge | Simple & Easy To Use’ but the transaction got stuck in a queue in the wallet (never sent the funds) and I now can’t seem to make any transactions with the MetaMask wallet. The transaction in Polyscan that I think this relates to is this - when i click on the 'to’ address and contract tab, it shows there’s a bug in Solidity, the exclamation mark symbol says ‘Solidity compiler bugs’ - not sure if that would affect things? Or could be the root of the error?

I’ve since tried to do a number of transactions but they all get stuck in queues and won’t let me move any funds - and none of these appear in Polygonscan. As an aside, on Polygonscan I can see a number of ! entries with the status 'Fail with error ‘Call to adapter failed’ (9 of these in total, first one here as an example). But these were prior to this issue I believe

I’ve reset my MetaMask wallet and tried sending Matic to my own address with some of the nonce info in the ! entries I can see in Polygonscan, but it just buffers and nothing gets sent (the ! entries seem to relate to me trying to swap matic for USDT rather than the bridge issue).

Can anyone help? Have I lost my funds? These are all the polyscan entries for the wallet address. I can still see the USDT balance and Matic in my wallet but can’t move them/do anything with them. Is there a way to fix this? If someone could take a look i’d be hugely grateful. Thanks in advance.

Hello @Jimmy Thanks for reaching to Polygon Forums.

Customer service may take some time to respond due to a large number of requests. We believe your case will be resolved as soon as possible.
Kindly visit the Matic support live chat website

Just to flag to anyone seeing this, this is a scam asking you to validate your wallet by entering your seed phrase

Thanks for responding. I’ve tried but it just buffers and doesn’t do anything. Is there anything else I can try?