Bridging to polygon didn't arrive in metamask wallet

I tried to bridge my Ethereum fromt he ethereum mainnet to the Matic Mainnet in my metamask wallet using the bridge function from the matic network page. Instead of the funds arriving in my metamask wallet they arrived in polygon technologies polygon wallet, and they appear to still be Ethereum. I paid fees to do this and I don’t want to pay more fees to get my funds where they’re supposed to be. Please advise how to correct this with as minimal cost as possible, etherescan of problem transaction below.

1 Like

@rassalas you can chat with our fastest support online MATIC NETWORK SUPPORT

I think I figured it out. I needed to add the wETH asset to my metamask wallet on the Polygon Mainnet. Now it shows up in my wallet.
Sorry I was unable to chat, and I had a similar problem on the umbria Narni bridge, and their discord support worked for me and also solved this problem. Sometime some people prefer to type rather than chat. Perhaps you should have that option for those of us who prefer written instructions.
Thank you